Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Symfony HTTP Foundation (symfony/http-foundation and symfony/symfony) is vulnerable in versions 2.7.0 through 2.7.48, 2.8.0 through 2.8.43, 3.3.0 through 3.3.17, 3.4.0 through 3.4.13, 4.0.0 through 4.0.13, and 4.1.0 through 4.1.2. Any client that can send requests to an affected application can use the X-Original-URL or X-Rewrite-URL headers to override the request path, enabling web cache poisoning. Upgrade to 2.7.49, 2.8.44, 3.3.18, 3.4.14, 4.0.14, or 4.1.3 as appropriate for your branch.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.5 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.58, the 99th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:32 UTC First seen by agentprime
- 31 Oct 2026, 14:32 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-8wgj-6wx8-h5hq
- OSV: GHSA-8wgj-6wx8-h5hq
- nvd.nist.gov/vuln/detail/CVE-2018-14773
- github.com/symfony/symfony/commit/e447e8b92148ddb3d1956b96638600ec95e08f6b
- github.com/FriendsOfPHP/security-advisories/blob/master/symfony/http-foundation/CVE-2018-14773.yaml
- github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2018-14773.yaml
- lists.debian.org/debian-lts-announce/2019/03/msg00009.html
- seclists.org/bugtraq/2019/May/21
- symfony.com/blog/cve-2018-14773-remove-support-for-legacy-and-risky-http-headers
- www.debian.org/security/2019/dsa-4441
- www.drupal.org/SA-CORE-2018-005
- www.securityfocus.com/bid/104943
- www.securitytracker.com/id/1041405