Advisory record · GHSA-8v8j-3hxp-93wr

Spring Boot's default security filter chain has no authorization rule with Actuator but without Health

CVSS 9.1 CriticalCriticalEPSS 0.0049 · 42nd percentile

Critical, because:

  • CVSS score 9.1: 9.0 or more.

How we decide what’s critical

Published by the GitHub Advisory Database at 28 Apr 2026, 00:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
org.springframework.boot:spring-bootMaven>=4.0.0, <4.0.64.0.6
Identifiers
GHSA-8v8j-3hxp-93wr · CVE-2026-40976
Weakness (CWE)
CWE-305 · CWE-862
Published
28 Apr 2026
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Spring Boot (org.springframework.boot:spring-boot is the affected package, but the name here is just "Spring Boot"), versions 4.0.0 through 4.0.5, has a default web security filter chain that can be ineffective, allowing unauthenticated access to all endpoints. Exploitation requires a servlet-based application with no Spring Security configuration of its own that depends on spring-boot-actuator-autoconfigure but not on spring-boot-health. Upgrade to Spring Boot 4.0.6 or later.

Written 2 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
9.1 Critical 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N CNA (vmware)
  • CISA KEV Not listed.
  • EPSS 0.0049, the 42nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:17 UTC First seen by agentprime
  2. 31 Oct 2026, 14:17 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.