Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GoBGP versions before 4.3.0 (github.com/osrg/gobgp/v4) can panic with an index out of range error when processing a malformed BGP UPDATE message containing AS_PATH and AS4_PATH attributes in an unusual order. An attacker who can send BGP UPDATE messages to a GoBGP peer, including through a transit provider, can crash the daemon and disrupt routing. Upgrade to version 4.3.0 or later. The source gives few details on workarounds.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0054, the 45th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:56 UTC First seen by agentprime
- 31 Oct 2026, 14:56 UTC Confirmed by OSV