Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The npm package handlebars, versions 4.0.0 up to but not including 4.7.10, is vulnerable to JavaScript injection through pre-parsed AST objects passed to compile() or precompile(). An attacker who can supply an object (such as a parsed JSON request body) to these functions can inject arbitrary JavaScript that runs on the server during rendering with compile(), or in wherever the precompiled output is loaded with precompile(). Upgrade to handlebars 4.7.10, which is the listed fixed version; applications that only pass template strings are not affected.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.8 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0079, the 56th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-8r5x-fm3f-whwj
- OSV: GHSA-8r5x-fm3f-whwj
- github.com/handlebars-lang/handlebars.js/security/advisories/GHSA-8r5x-fm3f-whwj
- nvd.nist.gov/vuln/detail/CVE-2026-106446
- github.com/handlebars-lang/handlebars.js/pull/2185
- github.com/handlebars-lang/handlebars.js/commit/703fdcc5fd6cc8d1cc0c33cc19de40c467c4b8d2
- github.com/handlebars-lang/handlebars.js
- github.com/handlebars-lang/handlebars.js/releases/tag/v4.7.10