Advisory record · GHSA-8r29-2mp2-pmrw

Payload Ecommerce has an order confirmation validation issue

CVSS 8.8 HighEPSS 0.0031 · 23rd percentile

Published by the GitHub Advisory Database at 6 Oct 2026, 16:17 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
@payloadcms/plugin-ecommercenpm<3.90.0 || >=4.0.0-canary.0, <4.0.0-canary.343.90.0, 4.0.0-canary.34
Identifiers
GHSA-8r29-2mp2-pmrw · CVE-2026-105850
Weakness (CWE)
CWE-837
Published
6 Oct 2026
Updated
6 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Payload's @payloadcms/plugin-ecommerce package, in versions below 3.90.0 and from 4.0.0-canary.0 up to but not including 4.0.0-canary.34, can process an order confirmation more than once under certain conditions when the Stripe payment adapter is used. The source does not describe what an attacker must do or what they gain, and it says deployments not using the Stripe flow are unaffected. Users should upgrade to 3.90.0 or 4.0.0-canary.34 or later; until then, the source suggests ensuring Stripe order confirmations can only be processed once as a temporary mitigation.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.8 High 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0031, the 23rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 13:34 UTC First seen by agentprime
  2. 31 Oct 2026, 13:34 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.