Advisory record · GHSA-8qxg-mff5-j3wc

RubyGems Path Traversal vulnerability

CVSS 5.5 MediumEPSS 0.028 · 86th percentile

Published by the GitHub Advisory Database at 14 May 2022, 01:54 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
rubygems-updateRubyGems<2.7.62.7.6
org.jruby:jruby-stdlibMaven<9.1.16.09.1.16.0
Identifiers
GHSA-8qxg-mff5-j3wc · CVE-2018-1000079
Weakness (CWE)
CWE-22
Published
14 May 2022
Updated
12 Mar 2024

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Two packages are affected: RubyGems rubygems-update before 2.7.6, and Maven org.jruby:jruby-stdlib before 9.1.16.0. The source describes a directory traversal flaw in gem installation that lets a malicious gem write files to arbitrary locations on the filesystem during installation. An attacker would need a user to install a crafted gem. Upgrade rubygems-update to 2.7.6 or later, and jruby-stdlib to 9.1.16.0 or later.

Written 8 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
5.5 Medium 3.0 CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS 0.028, the 86th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 15:13 UTC First seen by agentprime
  2. 31 Oct 2026, 15:13 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.