Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Langflow versions before 1.10.1 are vulnerable. Its Python Interpreter components execute user-supplied Python in-process without effective sandboxing, so any authenticated user who can edit and run a flow can execute arbitrary code with the service's privileges and escalate to superuser. Upgrade langflow to 1.10.1 or later, preferably 1.12.3 or later for the full hardening series.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 10.0 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H | CNA (ibm) |
- CISA KEV Not listed.
- EPSS 0.0082, the 57th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-8qpj-27x8-pwpq
- OSV: GHSA-8qpj-27x8-pwpq
- github.com/langflow-ai/langflow/security/advisories/GHSA-8qpj-27x8-pwpq
- nvd.nist.gov/vuln/detail/CVE-2026-10561
- github.com/langflow-ai/langflow/pull/13700
- github.com/langflow-ai/langflow/commit/2754c84aad1306f463db1c3bbb3e8ffbe85da77d
- github.com/langflow-ai/langflow
- github.com/langflow-ai/langflow/releases/tag/v1.10.1
- www.ibm.com/support/pages/node/7277242