Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Versions of xwiki-platform-oldcore from 2.0 before 14.10.7, and from 15.0-rc-1 before 15.2-rc-1, are affected. After an upgrade, old document revisions that still contain a previously fixed vulnerability can be executed, so an attacker with view rights may be able to run code and affect the whole installation. Upgrade to 14.10.7 or 15.2-rc-1; the source does not give a workaround beyond manually deleting old revisions of affected documents, which it notes is hard to do completely.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 10.0 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.019, the 79th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:21 UTC First seen by agentprime
- 31 Oct 2026, 14:21 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-8q9q-r9v2-644m
- OSV: GHSA-8q9q-r9v2-644m
- github.com/xwiki/xwiki-platform/security/advisories/GHSA-2g5c-228j-p52x
- github.com/xwiki/xwiki-platform/security/advisories/GHSA-8q9q-r9v2-644m
- nvd.nist.gov/vuln/detail/CVE-2023-36468
- github.com/xwiki/xwiki-platform/commit/15a6f845d8206b0ae97f37aa092ca43d4f9d6e59
- github.com/xwiki/xwiki-platform
- jira.xwiki.org/browse/XWIKI-20594