Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Affected versions of tensorflow, tensorflow-cpu and tensorflow-gpu are those before 2.1.4, from 2.2.0 before 2.2.3, from 2.3.0 before 2.3.3, and from 2.4.0 before 2.4.2. Calling tf.io.decode_raw with fixed_length and a wider datatype writes past the bounds of the output buffer, which can crash the Python interpreter; the source notes more severe attacks may be possible. Upgrade to 2.1.4, 2.2.3, 2.3.3, 2.4.2 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.1 | High | 3.1 | CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0022, the 12th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:37 UTC First seen by agentprime
- 31 Oct 2026, 14:37 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-8pmx-p244-g88h
- OSV: GHSA-8pmx-p244-g88h
- github.com/tensorflow/tensorflow/security/advisories/GHSA-8pmx-p244-g88h
- nvd.nist.gov/vuln/detail/CVE-2021-29614
- github.com/tensorflow/tensorflow/commit/698e01511f62a3c185754db78ebce0eee1f0184d
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-542.yaml
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-740.yaml
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-251.yaml
- github.com/tensorflow/tensorflow