Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Mistune versions before 3.3.0 are vulnerable to a denial of service in the Include directive: two markdown files that include each other cause unbounded recursion until Python raises a RecursionError, which is not caught and propagates out of the renderer. An attacker who can supply or write two markdown files that the application renders can crash rendering on demand. Upgrade mistune to 3.3.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0053, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:42 UTC First seen by agentprime
- 31 Oct 2026, 14:42 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-8mpj-m6qm-5qr8
- OSV: GHSA-8mpj-m6qm-5qr8
- github.com/lepture/mistune/security/advisories/GHSA-8mpj-m6qm-5qr8
- nvd.nist.gov/vuln/detail/CVE-2026-59927
- github.com/lepture/mistune/commit/1bef343ade163fc3bb95572b15be720084cdb993
- github.com/lepture/mistune
- github.com/lepture/mistune/releases/tag/v3.3.0
- github.com/pypa/advisory-database/tree/main/vulns/mistune/PYSEC-2026-2215.yaml