Advisory record · GHSA-8m2g-8cgm-3vcp

DeepSeek Harness contains an authentication bypass vulnerability in local HTTP control-plane API

CVSS 9.4 CriticalCriticalEPSS 0.012 · 69th percentile

Critical, because:

  • CVSS score 9.4: 9.0 or more.

How we decide what’s critical

Published by the GitHub Advisory Database at 8 Sept 2026, 18:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
@deepseek-ai/dsh-client-connectionnpm<0.1.2-alpha.10.1.2-alpha.1
Identifiers
GHSA-8m2g-8cgm-3vcp · CVE-2026-82533
Weakness (CWE)
CWE-807
Published
8 Sept 2026
Updated
7 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The npm package @deepseek-ai/dsh-client-connection, part of DeepSeek Harness, is affected before 0.1.2-alpha.1. Its local HTTP control-plane API validates only the client-supplied Host header rather than the actual connection origin, so an attacker can bypass authentication without a credential and gain full agent control, including privileged actions and access to stored conversations. Upgrade to 0.1.2-alpha.1 or later.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
9.4 Critical 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H CNA (VulnCheck)
  • CISA KEV Not listed.
  • EPSS 0.012, the 69th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 13:33 UTC First seen by agentprime
  2. 31 Oct 2026, 13:33 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.