Advisory record · GHSA-8j3q-gc9x-7972

Mattermost Incorrect Type Conversion or Cast

CVSS 6.5 MediumEPSS 0.0058 · 48th percentile

Published by the GitHub Advisory Database at 15 Jan 2025, 18:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
github.com/mattermost/mattermost/server/v8Go>=10.2.0, <10.2.1 || >=10.1.0, <10.1.4 || >=10.0.0, <10.0.4 || >=9.11.0, <9.11.6 || <8.0.0-20241127161322-25ff7a3779a510.2.1, 10.1.4, 10.0.4, 9.11.6, 8.0.0-20241127161322-25ff7a3779a5
Identifiers
GHSA-8j3q-gc9x-7972 · CVE-2025-21088 · GO-2025-3393
Weakness (CWE)
CWE-704
Published
15 Jan 2025
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Mattermost server (Go module github.com/mattermost/mattermost/server/v8) versions 8.0.0-20241127161322-25ff7a3779a5 and earlier, 9.11.0 through 9.11.5, 10.0.0 through 10.0.3, 10.1.0 through 10.1.3, and 10.2.0 are affected. An attacker can supply crafted input in a post's attachment action style, which crashes the frontend; the source gives few details on the required privileges. Upgrade to 8.0.0-20241127161322-25ff7a3779a5, 9.11.6, 10.0.4, 10.1.4, 10.2.1, or later.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.5 Medium 3.1 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CNA (Mattermost)
  • CISA KEV Not listed.
  • EPSS 0.0058, the 48th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:15 UTC First seen by agentprime
  2. 31 Oct 2026, 14:15 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.