Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
vm2 versions 3.11.4 up to 3.11.7 are affected. A NodeVM configured with nesting enabled and an array-shaped require option bypasses its configuration check, so an attacker who can supply JavaScript that the NodeVM executes can reach the host vm2 module and run commands as the host Node.js process. Upgrade to vm2 3.11.7, which the source lists as the fixed version.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.5 | Critical | 4.0 | CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0064, the 50th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:34 UTC First seen by agentprime
- 31 Oct 2026, 13:34 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-8hr7-r645-pc6w
- OSV: GHSA-8hr7-r645-pc6w
- github.com/patriksimek/vm2/security/advisories/GHSA-8hr7-r645-pc6w
- nvd.nist.gov/vuln/detail/CVE-2026-92935
- github.com/patriksimek/vm2/commit/05894eca1dc6a2b1a986f312c88255288a983d22
- github.com/patriksimek/vm2/commit/54b54b74a382577f0bcd0538c5bf99acdcd7f53b
- github.com/patriksimek/vm2
- github.com/patriksimek/vm2/releases/tag/v3.11.7
- www.vulncheck.com/advisories/vm2-nodevm-remote-code-execution-via-array-shaped-require