Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Coder's Go package github.com/coder/coder/v2 is affected in versions before 2.29.17, from 2.30.0 before 2.32.7, from 2.33.0 before 2.33.8, and from 2.34.0 before 2.34.2. An unauthenticated attacker who submits a login with the password "hunter2" can tell whether an account exists and which authentication method it uses, because the response codes differ. No authentication bypass or data access results. Upgrade to 2.29.17, 2.32.7, 2.33.8, or 2.34.2 depending on your release line; no workaround is listed.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.3 | Medium | 4.0 | CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0022, the 13th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:12 UTC First seen by agentprime
- 31 Oct 2026, 14:12 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-8fxq-53rx-ph5f
- OSV: GHSA-8fxq-53rx-ph5f
- github.com/coder/coder/security/advisories/GHSA-8fxq-53rx-ph5f
- github.com/coder/coder/pull/26205
- github.com/coder/coder/commit/35a7dc8ab9c7f15ce05d963947823ee31224512f
- github.com/coder/coder
- github.com/coder/coder/releases/tag/v2.29.17
- github.com/coder/coder/releases/tag/v2.32.7
- github.com/coder/coder/releases/tag/v2.33.8
- github.com/coder/coder/releases/tag/v2.34.2