Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Versions of pymonocypher before 4.0.2.8 are affected by a potential heap buffer overflow in argon2i_32 when the caller provides a buffer smaller than the API requires for nb_blocks. The source does not describe what kind of access an attacker needs, but a successful overflow could write past the buffer and corrupt the heap. Upgrade to pymonocypher 4.0.2.8, which checks that the buffer is large enough. Until then, provide a correctly sized buffer.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.1 | Medium | 4.0 | CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0018, the 7th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 15:02 UTC First seen by agentprime
- 31 Oct 2026, 15:02 UTC Confirmed by OSV