Advisory record · GHSA-8f3q-3jmv-7prw

Http4s Ember HTTP/2 has an unbounded outbound frame queue

CVSS 7.5 HighEPSS 0.0063 · 50th percentile

Published by the GitHub Advisory Database at 15 Sept 2026, 20:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
org.http4s:http4s-ember-core_2.12Maven<0.23.350.23.35
org.http4s:http4s-ember-core_2.13Maven<0.23.35 || >=1.0.0-M1, <1.0.0-M470.23.35, 1.0.0-M47
org.http4s:http4s-ember-core_3Maven<0.23.35 || >=1.0.0-M1, <1.0.0-M470.23.35, 1.0.0-M47
Identifiers
GHSA-8f3q-3jmv-7prw · CVE-2026-69213
Weakness (CWE)
CWE-400 · CWE-770
Published
15 Sept 2026
Updated
15 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Ember HTTP/2 in http4s-ember-core versions before 0.23.35, and in the 1.0.0-M1 through 1.0.0-M46 range for the 2.13 and 3 builds, has an unbounded outbound frame queue. A single unauthenticated connection from a malicious client, or a hostile server talking to an ember client, can make control frames pile up until the process runs out of memory. Upgrade http4s-ember-core to 0.23.35 or 1.0.0-M47. Until then, avoid enabling HTTP/2 by not calling withHttp2.

Written 2 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0063, the 50th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:16 UTC First seen by agentprime
  2. 31 Oct 2026, 14:16 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.