Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Semaphore UI (Go module github.com/semaphoreui/semaphore) is vulnerable to cross-site request forgery on its password change endpoint, affecting versions before 0.0.0-20260707190631-c59c3dc9035b. An attacker can host a malicious page that silently submits a password change for a user who is logged in, including an administrator, and then take over that account. The source reports the issue was tested on version 2.18.20. Upgrade to 0.0.0-20260707190631-c59c3dc9035b or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.3 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0023, the 14th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:13 UTC First seen by agentprime
- 31 Oct 2026, 14:13 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-8cj9-r88m-8945
- OSV: GHSA-8cj9-r88m-8945
- github.com/semaphoreui/semaphore/security/advisories/GHSA-8cj9-r88m-8945
- nvd.nist.gov/vuln/detail/CVE-2026-73292
- github.com/semaphoreui/semaphore/commit/2d6e2e3eb10e8bf688e2ab59609b909a012fad4c
- github.com/semaphoreui/semaphore/commit/c59c3dc9035badcbf0609c7d35679c06e590a956
- github.com/semaphoreui/semaphore
- github.com/semaphoreui/semaphore/releases/tag/v2.18.21