Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Summary: The rubygems-update package before 2.7.6 is vulnerable to cross-site scripting through the homepage attribute shown by the gem server. An attacker can run script in a victim's browser if the victim visits a malicious gem hosted on a vulnerable gem server. Upgrade rubygems-update to 2.7.6 or later. The jruby-stdlib package is also listed with a fix in 9.1.16.0, but the source gives no further details about it.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.1 | Medium | 3.0 | CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.027, the 86th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 15:13 UTC First seen by agentprime
- 31 Oct 2026, 15:13 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-87qx-g5wg-mwmj
- OSV: GHSA-87qx-g5wg-mwmj
- nvd.nist.gov/vuln/detail/CVE-2018-1000078
- github.com/jruby/jruby/commit/0b06b48ab4432237ce5fc1bef47f2c6bcf7843f7
- github.com/rubygems/rubygems/commit/5971b486d4dbb2bad5d3445b3801c456eb0ce183
- github.com/rubygems/rubygems/commit/66a28b9275551384fdab45f3591a82d6b59952cb
- www.debian.org/security/2018/dsa-4259
- www.debian.org/security/2018/dsa-4219
- usn.ubuntu.com/3621-1
- lists.debian.org/debian-lts-announce/2019/05/msg00028.html
- lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- lists.debian.org/debian-lts-announce/2018/04/msg00023.html
- lists.debian.org/debian-lts-announce/2018/04/msg00001.html
- lists.debian.org/debian-lts-announce/2018/04/msg00000.html