Advisory record · GHSA-8787-63px-3m23

Cobbler has Exposed Dangerous Method or Function

CVSS 9.8 CriticalCriticalEPSS 0.68 · 99th percentile

Critical, because:

  • CVSS score 9.8: 9.0 or more.
  • CVSS score 9.8 (7.0 or more) and EPSS 0.68 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical

Published by the GitHub Advisory Database at 13 May 2022, 01:54 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
cobblerPyPI>=2.6.0, <3.0.03.0.0
Identifiers
GHSA-8787-63px-3m23 · CVE-2018-10931 · PYSEC-2026-313
Weakness (CWE)
CWE-749
Published
13 May 2022
Updated
27 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The PyPI package cobbler, versions from 2.6.0 up to but not including 3.0.0, exposed all functions of its CobblerXMLRPCInterface class over XMLRPC. A remote attacker with no authentication could use this to gain elevated privileges in cobbler and upload files to arbitrary locations in the context of the daemon. Upgrade to cobbler 3.0.0, which contains the fix.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
9.8 Critical 3.0 CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CNA (redhat)
  • CISA KEV Not listed.
  • EPSS 0.68, the 99th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:07 UTC First seen by agentprime
  2. 31 Oct 2026, 14:07 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.