Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Weaviate (Go package github.com/weaviate/weaviate) versions below 1.18.6, from 1.19.0 up to but not including 1.19.13, and from 1.20.0 up to but not including 1.20.6 are affected by a type conversion issue that enables denial of service. The source gives few details about the attack conditions. Upgrade to 1.18.6, 1.19.13, or 1.20.6, depending on your release line; no workaround other than upgrading is listed.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.021, the 82nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-8697-479h-5mfp
- OSV: GHSA-8697-479h-5mfp
- github.com/weaviate/weaviate/security/advisories/GHSA-8697-479h-5mfp
- nvd.nist.gov/vuln/detail/CVE-2023-38976
- github.com/weaviate/weaviate/issues/3258
- github.com/weaviate/weaviate/pull/3431
- github.com/weaviate/weaviate/commit/2a7b208d9aca07e28969e3be82689c184ccf9118
- github.com/weaviate/weaviate
- github.com/weaviate/weaviate/releases/tag/v1.18.6
- github.com/weaviate/weaviate/releases/tag/v1.19.13
- github.com/weaviate/weaviate/releases/tag/v1.20.6