Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
PocketBase versions below 0.22.48, and from 0.23.0 up to but not including 0.39.7, can terminate the server process because panics in internal worker goroutines are not recovered; the request-handling middleware does not cover them. The source does not describe the specific trigger or what an attacker must send to reach it. Upgrade to PocketBase 0.39.7, or to 0.22.48 if you are on a version earlier than 0.23.0.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0058, the 47th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:12 UTC First seen by agentprime
- 31 Oct 2026, 14:12 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-84vh-m24q-wjjx
- OSV: GHSA-84vh-m24q-wjjx
- github.com/pocketbase/pocketbase/security/advisories/GHSA-84vh-m24q-wjjx
- nvd.nist.gov/vuln/detail/CVE-2026-82410
- github.com/pocketbase/pocketbase/commit/30b4184305904fae0d1b78216c4e3cc34700b220
- github.com/pocketbase/pocketbase/commit/f1618ee59b6d1c0308bb474c827a2b1f24b12a95
- github.com/pocketbase/pocketbase
- github.com/pocketbase/pocketbase/discussions/7762
- github.com/pocketbase/pocketbase/releases/tag/v0.22.48
- github.com/pocketbase/pocketbase/releases/tag/v0.39.7