Advisory record · GHSA-848f-mph5-9pm9

Zendframework Potential Information Disclosure and Insufficient Entropy vulnerability

CVSS 7.5 High

Published by the GitHub Advisory Database at 7 Jun 2024, 22:27 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
zendframework/zendframework1Packagist>=1.12.0, <1.12.171.12.17
Identifiers
GHSA-848f-mph5-9pm9 · PKSA-3bnk-phyr-4y6w
Weakness (CWE)
CWE-331
Published
7 Jun 2024
Updated
4 Dec 2024

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

zendframework/zendframework1 versions 1.12.0 up to but not including 1.12.17 select CAPTCHA words using PHP's array_rand(), which does not generate enough randomness. An attacker who can brute force the random number generation could disclose information from the CAPTCHA challenge. Upgrade to zendframework/zendframework1 1.12.17, which is the fixed version.

Written 4 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:28 UTC First seen by agentprime
  2. 31 Oct 2026, 14:28 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.