Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
FastMCP and fastmcp-slim versions 3.0.0 to before 3.4.10, and 4.0.0 to before 4.1.2, are affected. When a server transform changes a component's metadata, direct lookups return the transformed component without rechecking its authorization policy, so a client that knows the component identifier can invoke a tool or retrieve a resource or prompt that the policy denies. Upgrade to fastmcp or fastmcp-slim 3.4.10 or 4.1.2. Until then, avoid overlapping proxy templates for protected resources and enforce required authorization in the handler or at the server boundary.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.8 | Medium | 3.1 | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-7xgj-8392-5q4r
- OSV: GHSA-7xgj-8392-5q4r
- github.com/PrefectHQ/fastmcp/security/advisories/GHSA-7xgj-8392-5q4r
- github.com/PrefectHQ/fastmcp/pull/5933
- github.com/PrefectHQ/fastmcp/pull/5934
- github.com/PrefectHQ/fastmcp/commit/85df42fbf2aa631cc81e0f986718b314128e91df
- github.com/PrefectHQ/fastmcp/commit/8649ba5fc91a68568a69729497edeb804a064332
- github.com/PrefectHQ/fastmcp
- github.com/PrefectHQ/fastmcp/releases/tag/v3.4.10
- github.com/PrefectHQ/fastmcp/releases/tag/v4.1.2