Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
CodeIgniter4 framework versions before 4.7.4 are affected. In IncomingRequest::isSecure(), the X-Forwarded-Proto and Front-End-Https headers are trusted from any request, so an attacker who can reach the application over HTTP can spoof them and make an HTTP request appear secure, which may affect HTTPS-only enforcement. Upgrade to codeigniter4/framework 4.7.4 or later; if you cannot upgrade yet, enforce HTTP-to-HTTPS redirects at your web server or load balancer and make sure your reverse proxy strips or overwrites these forwarding headers.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 4.8 | Medium | 3.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0017, the 6th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:24 UTC First seen by agentprime
- 31 Oct 2026, 14:24 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-7wmf-pw8j-mc78
- OSV: GHSA-7wmf-pw8j-mc78
- github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-7wmf-pw8j-mc78
- nvd.nist.gov/vuln/detail/CVE-2026-63220
- github.com/codeigniter4/CodeIgniter4/commit/ecbf044666bed41d23f07518096d9843fe6c08b0
- github.com/codeigniter4/CodeIgniter4
- github.com/codeigniter4/CodeIgniter4/releases/tag/v4.7.4