Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Versions of the node-forge npm package before 1.4.1 are affected by a regular expression denial of service in its PEM decoding (pem.decode), which all PEM-parsing APIs use. A remote, unauthenticated attacker who can supply PEM text to an application, such as an uploaded certificate or key, can send a crafted input of a few tens of kilobytes to block the Node.js event loop for seconds to minutes. Upgrade to node-forge 1.4.1, which parses PEM messages and headers in linear time; the source notes that merely rejecting large PEM input only limits the delay.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0056, the 46th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:32 UTC First seen by agentprime
- 31 Oct 2026, 13:32 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-7wch-p9px-956x
- OSV: GHSA-7wch-p9px-956x
- github.com/digitalbazaar/forge/security/advisories/GHSA-7wch-p9px-956x
- nvd.nist.gov/vuln/detail/CVE-2026-118779
- github.com/digitalbazaar/forge/commit/412345db583cd28a9d23636d0d93e9f751b935f3
- github.com/digitalbazaar/forge
- github.com/digitalbazaar/forge/releases/tag/v1.4.1