Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Flask-CORS versions before 6.0.0 are affected. The source describes a flaw where longer regex path patterns take priority over more specific ones, so a less restrictive CORS policy can apply to sensitive endpoints, allowing cross-origin access to data or functionality. The source gives few details on the exact conditions an attacker needs. Upgrade flask-cors to version 6.0.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 4.3 | Medium | 3.0 | CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N | CNA (@huntr_ai) |
- CISA KEV Not listed.
- EPSS 0.0074, the 54th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:37 UTC First seen by agentprime
- 31 Oct 2026, 14:37 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-7rxf-gvfg-47g4
- OSV: GHSA-7rxf-gvfg-47g4
- nvd.nist.gov/vuln/detail/CVE-2024-6839
- github.com/corydolphin/flask-cors/commit/e970988bea563e05e8b8f53fa7bcc134b5bf5c5f
- github.com/corydolphin/flask-cors
- github.com/corydolphin/flask-cors/blob/4.0.1/flask_cors/core.py#L73
- huntr.com/bounties/403eb1fc-86f4-4820-8eba-0f3dfae9f2b4
- lists.debian.org/debian-lts-announce/2025/05/msg00049.html