Advisory record · GHSA-7mxx-3cgm-xxv3

API Platform Core does not call GraphQl securityAfterResolver

CVSS 4.4 MediumEPSS 0.0030 · 23rd percentile

Published by the GitHub Advisory Database at 24 Mar 2025, 16:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
api-platform/corePackagist>=3.3.8, <3.3.153.3.15
Identifiers
GHSA-7mxx-3cgm-xxv3 · CVE-2025-23204 · PKSA-jms4-fggn-5mmn
Weakness (CWE)
CWE-20 · CWE-484
Published
24 Mar 2025
Updated
24 Mar 2025

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

API Platform Core versions 3.3.8 before 3.3.15 have a GraphQL access-check bug: a security check meant to run after resolvers is replaced by another check because a switch clause lacks a break. Per the source, the impact applies only when a GraphQL operation has a security after resolver and no security check inside security, and the source gives few further details on exploitation. Upgrade api-platform/core to version 3.3.15, which is the listed fixed version.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
4.4 Medium 3.1 CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0030, the 23rd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:27 UTC First seen by agentprime
  2. 31 Oct 2026, 14:27 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.