Advisory record · GHSA-7m35-vw2c-696v

GoBGP panics due to a zero value for softwareVersionLen

CVSS 8.6 HighEPSS 0.0055 · 46th percentile

Published by the GitHub Advisory Database at 21 Apr 2025, 03:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
github.com/osrg/gobgp/v3Go>=3.11.0, <3.35.03.35.0
Identifiers
GHSA-7m35-vw2c-696v · CVE-2025-43971 · GO-2025-3631
Weakness (CWE)
CWE-193
Published
21 Apr 2025
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

GoBGP (github.com/osrg/gobgp/v3) versions 3.11.0 up to but not including 3.35.0 are affected. A remote attacker can send a crafted BGP message with a zero softwareVersionLen value to cause a panic, crashing the process. Upgrade to GoBGP 3.35.0 or later.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.6 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H CNA (mitre)
  • CISA KEV Not listed.
  • EPSS 0.0055, the 46th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:14 UTC First seen by agentprime
  2. 31 Oct 2026, 14:14 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.