Advisory record · GHSA-7hh9-gp72-wh7h

Auth0 Laravel SDK has Improper Audience Validation via Auth0-PHP SDK dependency

CVSS 6.8 Medium

Published by the GitHub Advisory Database at 17 Dec 2025, 20:55 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
auth0/loginPackagist>=7.0.0, <7.20.07.20.0
Identifiers
GHSA-7hh9-gp72-wh7h · PKSA-y6vp-t32r-dgs1
Weakness (CWE)
CWE-863 · CWE-1395
Published
17 Dec 2025
Updated
4 Feb 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The auth0/login package (Auth0 Laravel SDK) versions 7.0.0 through 7.19.0 are affected, along with applications that use the Auth0-PHP SDK versions 8.0.0 through 8.17.0. Because audience validation of access tokens is improper, an affected application may accept ID tokens as access tokens. The source gives few details on the attacker's position or required access. Upgrade auth0/login to version 7.20.0 or later.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.8 Medium 3.1 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:26 UTC First seen by agentprime
  2. 31 Oct 2026, 14:26 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.