Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
phpBB (Packagist package phpbb/phpbb) versions from 3.0.0 before 3.3.16, and 4.0.0-a1 before 4.0.0-a2, are vulnerable to Host header injection. When force_server_vars is disabled, the server hostname can be taken from the HTTP Host header and used to build the password reset link, so an attacker who can manipulate that header (for example through a misconfigured host setup or a webserver that does not validate it) could get reset emails pointing to an attacker-controlled domain, potentially leading to account takeover. Upgrade to phpBB 3.3.16 or 4.0.0-a2, which contain fixes.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.1 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0025, the 16th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:02 UTC First seen by agentprime
- 31 Oct 2026, 14:02 UTC Confirmed by OSV