Advisory record · GHSA-79v4-65xg-pq4g

Vulnerable OpenSSL included in cryptography wheels

CVSS 6.3 MediumEPSS 0.025 · 84th percentile

Published by the GitHub Advisory Database at 11 Feb 2025, 18:06 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
cryptographyPyPI>=42.0.0, <44.0.144.0.1
Identifiers
GHSA-79v4-65xg-pq4g · CVE-2024-12797 · PYSEC-2026-1284
Weakness (CWE)
CWE-392 · CWE-1395
Published
11 Feb 2025
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Vulnerable OpenSSL is bundled in cryptography wheels for versions >=42.0.0, <44.0.1, and the fix is in cryptography 44.0.1. The source gives few details about the OpenSSL flaw or what an attacker needs to exploit it. Users installing prebuilt cryptography wheels from PyPI should upgrade to 44.0.1; those building from source must upgrade their own OpenSSL.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.3 Medium 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L ADP (CISA-ADP)
  • CISA KEV Not listed.
  • EPSS 0.025, the 84th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:34 UTC First seen by agentprime
  2. 31 Oct 2026, 14:34 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.