Advisory record · GHSA-7972-pg2x-xr59

vLLM has Hardcoded Trust Override in Model Files Enables RCE Despite Explicit User Opt-Out

CVSS 8.8 HighEPSS 0.014 · 71st percentile

Published by the GitHub Advisory Database at 27 Mar 2026, 15:27 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
vllmPyPI>=0.10.1, <0.18.00.18.0
Identifiers
GHSA-7972-pg2x-xr59 · CVE-2026-27893 · PYSEC-2026-2297
Weakness (CWE)
CWE-501 · CWE-693
Published
27 Mar 2026
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

vLLM versions 0.10.1 up to but not including 0.18.0 are affected. Two model implementation files hardcode trust_remote_code=True when loading sub-components, so a user who set trust-remote-code to False can still have arbitrary Python code run when vLLM loads a malicious model repository. Upgrade to vLLM 0.18.0 or later, which contains the fix.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.8 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.014, the 71st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:34 UTC First seen by agentprime
  2. 31 Oct 2026, 14:34 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.