Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Laravel's laravel/framework package, versions before 5.5.40 and from 5.6.0 before 5.6.15, has an Encrypter component that can return false instead of raising an error when decryption fails. An attacker who can modify an encrypted payload before it is decrypted can trigger this, and the impact depends on whether the application compares the result loosely. Upgrade to 5.5.40 or 5.6.15 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
No source has published a CVSS score for this record yet.
- CISA KEV Not listed.
- EPSS No score.
Timeline
Sources
- GitHub Advisory Database: GHSA-7852-w36x-6mf6
- OSV: GHSA-7852-w36x-6mf6
- github.com/laravel/framework/commit/28e53f23a76206fb130e9a54eb95aa3f010e79c9
- github.com/laravel/framework/commit/886d261df0854426b4662b7ed5db6a1c575a4279
- github.com/FriendsOfPHP/security-advisories/blob/master/laravel/framework/2018-03-30-1.yaml
- github.com/laravel/framework
- medium.com/@taylorotwell/laravel-security-release-5-6-15-and-5-5-40-56f1257933a0