Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Stack exhaustion in pest_grammars before 2.9.3 can occur when the JsonParser parses deeply nested JSON, aborting the host process. An attacker who can supply JSON to an application that uses this parser without adequate resource limits can cause a denial of service. Upgrade to pest_grammars 2.9.3 or later, which also requires the updated pest runtime; applications that cannot upgrade should reject excessively nested input before parsing or set a conservative pest::set_call_limit() budget.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 3.3 | Low | 3.1 | CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L | OSV |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 14:24 UTC First seen by agentprime
- 31 Oct 2026, 14:24 UTC Confirmed by OSV