Advisory record · GHSA-74vm-87hj-r66f

kin-openapi openapi3filter: nil-pointer panic in ValidateResponse on a response header declared with content

CVSS 8.2 HighEPSS 0.0047 · 41st percentile

Published by the GitHub Advisory Database at 16 Oct 2026, 19:58 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
github.com/getkin/kin-openapiGo<0.146.00.146.0
Identifiers
GHSA-74vm-87hj-r66f · CVE-2026-100349 · GO-2026-6804
Weakness (CWE)
CWE-476
Published
16 Oct 2026
Updated
5 Nov 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Affected: kin-openapi (Go) versions before 0.146.0; fixed in 0.146.0. ValidateResponse panics with a nil pointer dereference when a spec declares a response header using content instead of schema, even though doc.Validate() accepts such a spec. An attacker who can supply or influence the spec can crash the process on any call to that operation, and the crash fires for every request, whether or not the response includes the header. Upgrade to 0.146.0 or later. Until then, use schema on the affected response headers or skip ValidateResponse for those operations.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.2 High 4.0 CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0047, the 41st percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:12 UTC First seen by agentprime
  2. 31 Oct 2026, 14:12 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.