Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Yamcs versions from 5.13.0 before 5.13.2 and before 5.12.8 are vulnerable to remote code execution through the templateArgs field of the instance creation and update API, because values are written into the instance config as unescaped YAML. An attacker with the CreateInstances privilege, or any unauthenticated user on a server without a security.yaml file, can inject a service that runs an arbitrary command as the Yamcs service account. Upgrade to Yamcs 5.13.2 or 5.12.8. Until then, require authentication and withhold CreateInstances from users who should not have shell access.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.8 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0078, the 56th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:19 UTC First seen by agentprime
- 31 Oct 2026, 14:19 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-73mf-m39p-wpm9
- OSV: GHSA-73mf-m39p-wpm9
- github.com/yamcs/yamcs/security/advisories/GHSA-73mf-m39p-wpm9
- github.com/yamcs/yamcs/commit/549f295cf8c5496a5e799d6bec2432ef976c82aa
- github.com/yamcs/yamcs/commit/7192da1c49bdf5ab1d72e579a47766a7c43e87c8
- github.com/yamcs/yamcs
- github.com/yamcs/yamcs/releases/tag/yamcs-5.12.8
- github.com/yamcs/yamcs/releases/tag/yamcs-5.13.2