Advisory record · GHSA-72qj-48g4-5xgx

JRuby-OpenSSL has hostname verification disabled by default

CVSS 5.7 MediumEPSS 0.0020 · 9th percentile

Published by the GitHub Advisory Database at 7 May 2025, 17:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
rubygems:jruby-opensslMaven>=0.12.1, <0.15.40.15.4
org.jruby:jrubyMaven>=10.0.0.0, <10.0.0.1 || >=9.3.4.0, <9.4.12.110.0.0.1, 9.4.12.1
jruby-opensslRubyGems>=0.12.1, <0.15.40.15.4
Identifiers
GHSA-72qj-48g4-5xgx · CVE-2025-46551
Weakness (CWE)
CWE-295 · CWE-297
Published
7 May 2025
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The jruby-openssl package (RubyGems, and as a Maven artifact) versions 0.12.1 up to but not including 0.15.4 do not check that a server's certificate hostname matches the host being connected to, so SSL connections accept any valid certificate. An attacker able to intercept network traffic (a man-in-the-middle) could present a valid certificate for a different domain and the connection would succeed. Upgrade jruby-openssl to 0.15.4, and upgrade org.jruby:jruby to 10.0.0.1 or 9.4.12.1, which include the fix.

Written 2 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
5.7 Medium 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0020, the 9th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:17 UTC First seen by agentprime
  2. 31 Oct 2026, 14:17 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.