Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The crass package (RubyGems) before 1.0.7 is vulnerable. An attacker who can supply CSS strings to an application that parses them with Crass can make it use excessive CPU and memory on a very small input, which may crash the process. Upgrade to crass 1.0.7 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.9 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0039, the 32nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:21 UTC First seen by agentprime
- 31 Oct 2026, 14:21 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-6wmf-3r64-vcwv
- OSV: GHSA-6wmf-3r64-vcwv
- github.com/rgrove/crass/security/advisories/GHSA-6wmf-3r64-vcwv
- github.com/rgrove/crass
- github.com/rgrove/crass/releases/tag/v1.0.7
- github.com/rubysec/ruby-advisory-db/blob/master/gems/crass/GHSA-6wmf-3r64-vcwv.yml
- rubygems.org/gems/crass/versions/1.0.7