Advisory record · GHSA-6wjw-qf87-fv5v

Laravel Encrypter Failure to decryption vulnerability

No CVSS score

Published by the GitHub Advisory Database at 15 May 2024, 22:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
illuminate/encryptionPackagist>=5.5.0, <5.5.40 || >=5.6.0, <5.6.155.5.40, 5.6.15
Identifiers
GHSA-6wjw-qf87-fv5v · PKSA-39gh-mqn7-cm7d
Weakness (CWE)
CWE-1240
Published
15 May 2024
Updated
29 Nov 2024

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Laravel's illuminate/encryption package, versions 5.5.0 before 5.5.40 and 5.6.0 before 5.6.15, can fail on decryption and return false unexpectedly. An attacker who can modify the encrypted payload before it is decrypted could cause unexpected application behavior, particularly where weak type comparisons are used on the result. Upgrade to version 5.5.40 or 5.6.15.

Written 4 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

No source has published a CVSS score for this record yet.

  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:29 UTC First seen by agentprime
  2. 31 Oct 2026, 14:29 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.