Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
vm2 versions 3.11.3 up to but not including 3.11.7 expose the node:sqlite module to NodeVM code when that builtin is allowed explicitly or through the wildcard builtin setting. An untrusted plugin running in the sandbox can load a native library bundled in its own package, which runs native code in the host Node.js process outside the sandbox. Upgrade to vm2 3.11.7, the fixed version.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.4 | Critical | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0062, the 49th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:34 UTC First seen by agentprime
- 31 Oct 2026, 13:34 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-6w8r-xxw2-g3hx
- OSV: GHSA-6w8r-xxw2-g3hx
- github.com/patriksimek/vm2/security/advisories/GHSA-6w8r-xxw2-g3hx
- nvd.nist.gov/vuln/detail/CVE-2026-92938
- github.com/patriksimek/vm2/commit/aa146a77f859325e079f3bfbfe6d8309af483daa
- github.com/patriksimek/vm2
- github.com/patriksimek/vm2/releases/tag/v3.11.7
- www.vulncheck.com/advisories/vm2-3.11.3-through-3.11.6-remote-code-execution-via-node-sqlite