Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
OpenMage LTS (Packagist package openmage/magento-lts) versions before 20.17.0 are affected by a path traversal filter bypass in the Dataflow module. An authenticated administrator with network access can use a crafted file name to read arbitrary files from the server, such as configuration files. Upgrade to version 20.17.0 or later. Until then, restrict Dataflow access to trusted administrators or disable the module if it is not in use.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 4.9 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0050, the 43rd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:25 UTC First seen by agentprime
- 31 Oct 2026, 14:25 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-6vqf-6fhm-7rc6
- OSV: GHSA-6vqf-6fhm-7rc6
- github.com/OpenMage/magento-lts/security/advisories/GHSA-6vqf-6fhm-7rc6
- nvd.nist.gov/vuln/detail/CVE-2026-25525
- github.com/OpenMage/magento-lts/pull/5445
- hackerone.com/reports/3482926
- github.com/OpenMage/magento-lts
- github.com/OpenMage/magento-lts/releases/tag/v20.17.0