Advisory record · GHSA-6v2p-p543-phr9

golang.org/x/oauth2 Improper Validation of Syntactic Correctness of Input vulnerability

CVSS 7.5 HighEPSS 0.0087 · 58th percentile

Published by the GitHub Advisory Database at 18 Jul 2025, 17:27 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
golang.org/x/oauth2Go<0.27.00.27.0
Identifiers
GHSA-6v2p-p543-phr9 · CVE-2025-22868 · GO-2025-3488
Weakness (CWE)
CWE-1286
Published
18 Jul 2025
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

golang.org/x/oauth2 versions before 0.27.0 are vulnerable. An attacker who can supply a maliciously malformed token can cause excessive memory to be consumed during parsing. Upgrade to version 0.27.0 or later.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS 0.0087, the 58th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:14 UTC First seen by agentprime
  2. 31 Oct 2026, 14:14 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.