Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Hazelcast (Maven package com.hazelcast:hazelcast) versions before 5.7.0 are affected. A low-privileged malicious client can read arbitrary memory from cluster members and may crash members, or in some Enterprise Edition configurations corrupt memory, potentially leading to remote code execution. Upgrade to 5.7.0, or for Enterprise Edition, to 5.6.1, 5.5.10, or 5.4.5; restrict cluster access to trusted clients only if an upgrade cannot be applied immediately.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.3 | Critical | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0038, the 32nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-6v25-8wq6-xq4j
- OSV: GHSA-6v25-8wq6-xq4j
- github.com/hazelcast/hazelcast/security/advisories/GHSA-6v25-8wq6-xq4j
- github.com/hazelcast/hazelcast/commit/361979da12f18950c24719db832ca6c5e7c0534f
- docs.hazelcast.com/hazelcast/5.7/release-notes/community
- docs.hazelcast.com/hazelcast/5.7/release-notes/enterprise
- github.com/hazelcast/hazelcast
- github.com/hazelcast/hazelcast/releases/tag/v5.7.0