Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
xxl-job-admin versions before 3.2.0 are affected by an authorization bypass in the getJobsByGroup function, where manipulating the jobGroup argument causes improper control of resource identifiers. A remote attacker can exploit this, and the exploit has been publicly disclosed. Upgrade to xxl-job-admin 3.2.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.3 | Medium | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P | CNA (VulDB) |
- CISA KEV Not listed.
- EPSS 0.0034, the 27th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:20 UTC First seen by agentprime
- 31 Oct 2026, 14:20 UTC Confirmed by OSV