Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
vLLM versions before 0.24.0 are vulnerable to a memory exhaustion denial of service through the /v1/audio/transcriptions endpoint. The endpoint checks only the compressed upload size, so a small, compressed audio file can decode into many gigabytes of audio data in memory. An unauthenticated attacker can send a few concurrent requests to exhaust server memory. Upgrade to vLLM 0.24.0 or later, which contains the fix.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.5 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0042, the 36th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-6pr9-rp53-2pmc
- OSV: GHSA-6pr9-rp53-2pmc
- github.com/vllm-project/vllm/security/advisories/GHSA-6pr9-rp53-2pmc
- nvd.nist.gov/vuln/detail/CVE-2026-54233
- github.com/vllm-project/vllm/pull/44970
- github.com/vllm-project/vllm/commit/1b1359c33269446f13c05da9a90c25174cbea590
- github.com/advisories/GHSA-6pr9-rp53-2pmc
- github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-3404.yaml
- github.com/vllm-project/vllm
- github.com/vllm-project/vllm/releases/tag/v0.23.1rc0
- pypi.org/project/vllm