Advisory record · GHSA-6pjx-3pjc-mrj8

Apache Thrift Python bindings have an Improper Handling of Highly Compressed Data (Data Amplification) vulnerability

CVSS 7.5 HighEPSS 0.010 · 63rd percentile

Published by the GitHub Advisory Database at 27 Jul 2026, 12:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
thriftPyPI<0.24.00.24.0
Identifiers
GHSA-6pjx-3pjc-mrj8 · BIT-thrift-2026-41608 · CVE-2026-41608 · PYSEC-2026-3925
Weakness (CWE)
CWE-409
Published
27 Jul 2026
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Apache Thrift Python bindings (package thrift) before 0.24.0 are vulnerable to data amplification from highly compressed data. The source gives few details on how the attack is carried out or what access is required. Upgrade thrift to version 0.24.0, which fixes the issue.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS 0.010, the 63rd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:10 UTC First seen by agentprime
  2. 31 Oct 2026, 14:10 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.