Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
vLLM versions from 0.22.0 before 0.24.0 are affected by a denial of service flaw in the Rust gRPC frontend, where logprob_token_ids limits can be bypassed. A remote attacker can send Generate or GenerateStream requests with output logprobs enabled and more than 128 candidate token IDs, which triggers a fatal sampler exception and terminates the EngineCore process. The source does not describe any authentication requirement. Upgrade vllm to version 0.24.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.2 | High | 4.0 | CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0034, the 27th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV