Advisory record · GHSA-6j52-38f8-qhxr

Shopify App: Token exchange shop context confusion may allow cross-shop authorization bypass in affected apps

CVSS 7.6 HighEPSS 0.0075 · 55th percentile

Published by the GitHub Advisory Database at 29 Oct 2026, 16:39 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
shopify_appRubyGems>=22.1.0, <23.0.323.0.3
Identifiers
GHSA-6j52-38f8-qhxr · CVE-2026-63414
Weakness (CWE)
CWE-863
Published
29 Oct 2026
Updated
29 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The shopify_app RubyGems package, versions 22.1.0 up to but not including 23.0.3, can let a request authenticated for one shop be treated as another shop when it includes a different shop query parameter. An attacker holding a valid Shopify session token for one shop could reach shop-scoped data or actions of another shop, if the application relied on current_shopify_domain or params[:shop] for authorization or tenant lookup. Upgrade to shopify_app 23.0.3, which rejects mismatched requests with 401 Unauthorized.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.6 High 4.0 CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0075, the 55th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 30 Oct 2026, 22:49 UTC Confirmed by the CVE List
  2. 30 Oct 2026, 23:17 UTC Confirmed by NVD
  3. 31 Oct 2026, 14:21 UTC First seen by agentprime
  4. 31 Oct 2026, 14:21 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.