Advisory record · GHSA-6fj4-rcr3-r7rr

lopdf has a stack overflow via deeply nested PDF objects

CVSS 7.5 High

Published by the GitHub Advisory Database at 16 Oct 2026, 19:55 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
lopdfcrates.io<0.42.00.42.0
Identifiers
GHSA-6fj4-rcr3-r7rr · RUSTSEC-2026-0187
Weakness (CWE)
CWE-1124
Published
16 Oct 2026
Updated
17 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The lopdf Rust crate, versions before 0.42.0, is vulnerable to a stack overflow when parsing deeply nested PDF arrays or dictionaries through its load functions such as load_mem. An attacker who can supply a crafted PDF of roughly 21 KB, for example to a service that parses untrusted files, can crash the process with an abort, which causes a denial of service. Upgrade lopdf to version 0.42.0 or later.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:24 UTC First seen by agentprime
  2. 31 Oct 2026, 14:24 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.