Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
OpenAM's WebAuthn authentication module, Maven package org.openidentityplatform.openam:openam-auth-webauthn, is vulnerable to Java deserialization of untrusted data in versions before 16.1.1. An attacker who can write attacker-controlled data to the storage attribute the module reads, and who can reach the WebAuthn flow, could run arbitrary code as the application server user. Upgrade to version 16.1.1.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.2 | Critical | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0069, the 52nd percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-6c99-87fr-6q7r
- OSV: GHSA-6c99-87fr-6q7r
- github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-6c99-87fr-6q7r
- nvd.nist.gov/vuln/detail/CVE-2026-45051
- github.com/OpenIdentityPlatform/OpenAM/commit/8b02328d36bc9cd40602128a6d399d1eda9e6753
- github.com/OpenIdentityPlatform/OpenAM
- github.com/OpenIdentityPlatform/OpenAM/releases/tag/16.1.1